Bug: no preview in AE after adding bones to pins

Rigging, animation, import/export of characters, props and cameras comprehensive tool set for After Effects.
Forum rules
Please read these rules and advices before posting.
  • Before you ask any question about a tool, to avoid duplicates, please:
    1. Search for a solution in the available documentation for the tools.
    2. Some video tutorials and quicktips are available.
    3. You can make a search to see if your question has already been asked.
  • Thank you for giving a detailed and precise title to your topics, to help searching in the future.
  • We're very few people to manage this forum, please be patient if we're a bit long to answer.
  • Don't hesitate to answer to other people's questions! The goal of this forum is not only to have the Rainbox team answer users' questions, but to have everyone sharing and helping each other.
  • Finally, please always be polite, and keep in mind that all we want is sharing techniques and knowledge, helping each other.
Post Reply
Posts: 1
Joined: Fri Jan 31, 2020 10:16 am

Bug: no preview in AE after adding bones to pins

Post by DarkRaven » Fri Jan 31, 2020 10:52 am

Hi. I've encountered an issue with DUIK Bassel.2. After Effects does not render/show preview at all after adding Bones to Puppet Pins (only grey background remains in "Composition" window). This does not happen straightforward after clicking "Add Bones" – everything runs fine, I can move/rotate the bones to control puppet pins of my layer and just after some time After Effect no longer displays the preview image in composition window. There is no blue bar that is usually telling me that AE is rendering the preview image – it seems that it is no longer trying to render the image even though I don't have CapsLock button on. Just dark-grey background. I've tried purging All Memory and Disk Cache as well as reopening After Effects, rebooting etc. but nothing seems to help. This bug repeated 3 times – I had to open the Auto-Save files of a state before adding the bones. This did not happen before with projects without DUIK. I've tried upgrading my CC 2018 version to CC 2019 and it worked, but today when I was adding bones to another layer the issue once again occured under CC 2019. I prefer not to run CC 2020 because I've heard it is unstable with OSX. I installed the newest version of DUIK just yesterday – I was using an older version of DUIK with CC 2018 a few months ago but as I remember there was an issue with attaching bones to the "Advanced" Puppet Pin system that was introduced by Adobe recently and I had to use Legacy Puppet Pin system that produced less natural effects. That's why I've installed the newest version of DUIK yesterday and I'm using those "Advanced" Pins with Bones attached so I can make some parenting and animate the pins using bones' "rotation" rather than "position". And it worked yesterday, I've created nice-looking animation but today as I'm trying to do similar task with another layer, this bug occurs for the third time. Thanks for help in advance.

My setup is:
DUIK Bassel 2
After Effects CC 2018 and 2019
OSX 10.15.2 Catalina,
3.2 GHz 4-core i5
Radeon Pro 570 (4 GB VRAM)
27'' 5K Retina dispay

Those AE layers are PSD files' layers (PSD file was imported as a composition)
All files are on external HDD which runs pretty slow I must say, but I have no problems to access/open the source files in Photoshop.

User avatar
Posts: 737
Joined: Mon Jun 20, 2016 2:59 pm

Re: Bug: no preview in AE after adding bones to pins

Post by Duduf » Tue Feb 04, 2020 8:10 am

This looks like a bug from Ae, which I believed was fixed some time ago.
It happens with the advanced puppet engine when the pins have some expressions like the ones used by the bones in Duik. The best would be either to revert to the legacy engine or try with Ae 2020. I'm pretty sure it's been fixed, so maybe it's in 2020. Which IS stable, and has far better performance than CC2019

Post Reply