Page 1 of 1

Spine auto-rig falure (Possible bug report?)

Posted: Sun Mar 15, 2020 4:58 pm
by SuddenlyZach
Hey - fairly new DUIK user here so pardon any ignorance.

I'm trying to create a rig using structures but DUIK keep getting stuck. At first I had an entire Hominid Structure selected and tried clicking auto-rig. This failed, getting stuck with the "magic is happening" comp on the screen. It created a few controllers in the character comp, but none of them were linked to the structure.

Tired this a few times, and even in a fresh project with only a Hominid - still failed.

So I thought maybe I could do this piece by piece.

I created arms, auto-rigged them, and they worked. I created legs, auto rigged them, and they worked. It was when I got to a spine structure that the error occurred again. Seems that the spine in particular is messed up.

I'm still really learning the basics here and am unsure if there is an older, or "classic" way to work around this. Could it be user error on my part? Suggestions would be appreciated.

If it turns out to be a bug, I can do my best to provide more details on the issue to help solve it.

- Zach

Re: Spine auto-rig falure (Possible bug report?)

Posted: Wed Mar 18, 2020 12:24 pm
by Duduf
Hi Zach, thanks for your feedback.

That is strange, and the spine auto-rig should work as easily as the other limbs... Can you file a bug report on github, using the bug report button at the bottom of the Duik Panel? We'll investigate and try to see what's going wrong.
Also, make sure to state what is your exact version of Duik (as displayed on the panel) and of After Effects (as displayed in the about box in the help menu).
You can also enable "dev & debug" mode in Duik settings, and/or javascript debugging in the Ae preferences, and post any error shown by After Effects/Duik when the auto-rig fails.