Foot Roll isn't working!

Rigging, animation, import/export of characters, props and cameras comprehensive tool set for After Effects.
Forum rules
Please read these rules and advices before posting.
  • Before you ask any question about a tool, to avoid duplicates, please:
    1. Search for a solution in the available documentation for the tools.
    2. Some video tutorials and quicktips are available.
    3. You can make a search to see if your question has already been asked.
  • Thank you for giving a detailed and precise title to your topics, to help searching in the future.
  • We're very few people to manage this forum, please be patient if we're a bit long to answer.
  • Don't hesitate to answer to other people's questions! The goal of this forum is not only to have the Rainbox team answer users' questions, but to have everyone sharing and helping each other.
  • Finally, please always be polite, and keep in mind that all we want is sharing techniques and knowledge, helping each other.
Post Reply
El_Temple
Posts: 3
Joined: Mon Nov 09, 2020 7:02 pm

Foot Roll isn't working!

Post by El_Temple » Mon Nov 09, 2020 7:15 pm

Hi,
I'm new to Duik and using some tutorials I built a character rig and everything is working fine except for the foot roll function but only in the case of one foot!
In the image I have attached the Left foot (our Right) and the Right foot (our Left) have the same amount of foot roll used - -20
but both react completely different to the foot roll.

Please help! I've been pulling my hair out for two days now trying to figure it out!

El_Temple
Posts: 3
Joined: Mon Nov 09, 2020 7:02 pm

Re: Foot Roll isn't working!

Post by El_Temple » Mon Nov 09, 2020 7:17 pm

Apparently i can't add a photo but basically one foot is warped like it is supposed to be and the other is rigid and at an angle pointing downwards -20 degrees

User avatar
leastrym
Posts: 10
Joined: Fri Dec 13, 2019 10:01 am

Re: Foot Roll isn't working!

Post by leastrym » Tue Nov 10, 2020 10:13 am

Hi,
it is difficult to tell without picture, you should be able to add an attachement, try with a .jpg picture. Check if there's no something different between the effect panel of your Right Foot Controller and your Left Foot Controller. If there isn't, check in the expressions of both Feet controllers layers.

TobiTobi
Posts: 6
Joined: Fri Jan 08, 2021 8:00 am

Re: Foot Roll isn't working!

Post by TobiTobi » Fri Jan 08, 2021 8:22 am

Hi there!
I have the exact same problem (I think).

Image

- When using foot roll, the heels strangely stick to the ground (see picture)
- Same thing happens when I create a walk cycle, only the feet are lifted from the ground
- Also, the foot roll only works on foot 1, but rolls both feet. When I use it on foot 1, nothing happens.

Image

Image

- I realized that my heel structures are connected to the seemingly wrong feet (see pics above)...
- but if I change it to the corresponding feet, it doesn't change anything

I should mention that I did the rigging by creating a hominoid structure, then using auto-rig. I didn't (knowingly) change any settings.

TobiTobi
Posts: 6
Joined: Fri Jan 08, 2021 8:00 am

Re: Foot Roll isn't working!

Post by TobiTobi » Fri Jan 08, 2021 8:38 am

Okay, I just found out that I can create a demo fully riggend homonoid with a walk cycle by alt-clicking the homonoid button.
Strangely, this one is very differently connected, the heel structures go to the tiptoe structures.

When trying to set up my own rig like that, I relized that AE greys out my tiptoe structure when I try to connect my heels to it.
What's happening...?

I have also found a Youtube video where someone has the same sticky heels problem:

https://www.youtube.com/watch?v=8nk97DW ... e=youtu.be

TobiTobi
Posts: 6
Joined: Fri Jan 08, 2021 8:00 am

Re: Foot Roll isn't working!

Post by TobiTobi » Fri Jan 08, 2021 8:46 am

Also, this guy seems to have the same problem, also the connections are the same as in my rig (but not as in the demo walk cycle):
http://rainboxprod.coop/forum/viewtopic ... e34b45479b

TobiTobi
Posts: 6
Joined: Fri Jan 08, 2021 8:00 am

Re: Foot Roll isn't working!

Post by TobiTobi » Fri Jan 08, 2021 10:13 am

So I set up a completely new project and rigged my character again.
I still have the same problem of the sticky heels, however, I can now individually use foot roll for each foot using its controler.
The heels are now connected to their respective foot controllers (not like before, where they were connected to the controllers of the opposite foot).
But again, when trying to connect them to the tiptoes like the Duik demo rig is connected, the tiptoes are greyed out.

Please help!

User avatar
Duduf
Posts: 906
Joined: Mon Jun 20, 2016 2:59 pm

Re: Foot Roll isn't working!

Post by Duduf » Mon Jan 18, 2021 9:02 am

Can you send me an Aep so I can have a look?
Or grab a video recording of your rigging process?

susted
Posts: 1
Joined: Mon Jan 18, 2021 9:20 pm

Re: Foot Roll isn't working!

Post by susted » Mon Jan 18, 2021 9:22 pm

Hi! Did you find a solution to this?
I've been having the same issue with sticky heels.

Edit: I only just now saw that your reply was from earlier today. Fair enough if you haven't solved it yet ;)
I'll leave my post here, to add my voice to the ones having this issue.

User avatar
Duduf
Posts: 906
Joined: Mon Jun 20, 2016 2:59 pm

Re: Foot Roll isn't working!

Post by Duduf » Tue Jan 19, 2021 9:48 am

Or send me an aep ;)
I can't solve the issue without having a look at what's failing on your side

Post Reply