After rigging the face, the face is randomly moved from its original position.

Rigging, animation, import/export of characters, props and cameras comprehensive tool set for After Effects.
Forum rules
Please read these rules and advices before posting.
  • Before you ask any question about a tool, to avoid duplicates, please:
    1. Search for a solution in the available documentation for the tools.
    2. Some video tutorials and quicktips are available.
    3. You can make a search to see if your question has already been asked.
  • Thank you for giving a detailed and precise title to your topics, to help searching in the future.
  • We're very few people to manage this forum, please be patient if we're a bit long to answer.
  • Don't hesitate to answer to other people's questions! The goal of this forum is not only to have the Rainbox team answer users' questions, but to have everyone sharing and helping each other.
  • Finally, please always be polite, and keep in mind that all we want is sharing techniques and knowledge, helping each other.
Post Reply
kjung1
Posts: 2
Joined: Tue Jan 12, 2021 4:46 pm

After rigging the face, the face is randomly moved from its original position.

Post by kjung1 » Tue Jan 12, 2021 5:16 pm

Hi!

Hope I didn't miss anything from FAQ page...
I'm currently using duik to rig and animate the character for the group project.
So I was trying to open the rigged file that one of my friends did.
And all the face features except the front hair and base face are re-positioned far away from its original position.
When we repositioned this, the whole rig got messed up.
Two people only have this issue and other people have no problem with it.
But strangely when two people save this file on our end, it gives the same issue to other people.
I've updated the latest version of duik but it still gives me the same problem.
We're sitting here plucking our hair all day thanks to this...
If Duduf or anybody gives me a godsend advice for this issue, it would be truly amazing!

Thank you so much!
I will attach the screenshot of my After Effect screen.
https://www.dropbox.com/s/kmve7iheri1il ... M.png?dl=0

User avatar
Duduf
Posts: 900
Joined: Mon Jun 20, 2016 2:59 pm

Re: After rigging the face, the face is randomly moved from its original position.

Post by Duduf » Mon Jan 18, 2021 9:02 am

Hi!

This is strange, but I don't think it's an issue with Duik; I'd say you have several versions of the design (was it made in Ai?) and some of you have different versions, with different layer sizes, something like that...

Try to assemble the files from a working AEP, and use that on the other computers to see if it works. Also check that you have the same version of After Effects everywhere

kjung1
Posts: 2
Joined: Tue Jan 12, 2021 4:46 pm

Re: After rigging the face, the face is randomly moved from its original position.

Post by kjung1 » Wed Feb 03, 2021 11:16 pm

Hi Duduf,

Thank you so much for your helpful advice.
Luckily the problem has been solved magically thanks to your advice!

The source of problem was each team member's different version of After Effects.

This problem only happened to people who had version under 17.1.2 and the other members who didn't have the problem all had the version above 17.5.
When I upgrade my AE to v17.6, the rig works magically!

But I'm still wondering why this didn't occur on other rigs except this specific rig.
Maybe is it because this happens randomly..?
I don't know yet...

But I really appreciate your help!!

User avatar
Duduf
Posts: 900
Joined: Mon Jun 20, 2016 2:59 pm

Re: After rigging the face, the face is randomly moved from its original position.

Post by Duduf » Thu Feb 04, 2021 7:21 am

It's pretty usual to have this kind of random issues when working together with different versions of a software, and you never know why ;)
taking care of these comes with the experience in working in studio, and from the TD always preventing people from updating their software :D

Post Reply