Controller extraction does not work

Rigging, animation, import/export of characters, props and cameras comprehensive tool set for After Effects.
Forum rules
Please read these rules and advices before posting.
  • Before you ask any question about a tool, to avoid duplicates, please:
    1. Search for a solution in the available official user guide.
    2. Some video tutorials are available.
    3. Maybe you can find an answer in the frequently asked questions (FAQ).
    4. You can make a search to see if your question has already been asked.
    • Thank you for giving a detailed and precise title to your topics, to help searching in the future.
    • We're very few people to manage this forum, please be patient if we're a bit long to answer.
    • Don't hesitate to answer to other people's questions! The goal of this forum is not only to have the Rainbox team answer users' questions, but to have everyone sharing and helping each other.
    • Finally, please always be polite, and keep in mind that all we want is sharing techniques and knowledge, helping each other.
Post Reply
Ghezzi
Posts: 8
Joined: Thu Nov 29, 2018 2:00 pm

Controller extraction does not work

Post by Ghezzi » Thu Aug 22, 2019 11:18 am

Hello!

I have such a problem.
I have a composition in which several elements are controlled by controllers with DUIK.
I insert this composition into another and do "extract controllers". All controllers are removed, but their movement does not affect anything.
I do this all the time, but this time it’s not working.

Previously, in the primary composition, from where I extracted the controllers, this code was put in different elements:

//Duik.link
var timeLayer = comp ("Ani_Body_Layers"). layer ("Ani_Head_Layers");
var st = timeLayer.startTime;
var t = time + st;
comp ("Ani_Body_Layers"). layer ("Eye CTRL L"). effect ("Position Connector") (2) .valueAtTime (t);

Now this is not happening.

On all controllers there is a tag "controller" with DUIK.

Ghezzi
Posts: 8
Joined: Thu Nov 29, 2018 2:00 pm

Re: Controller extraction does not work

Post by Ghezzi » Thu Aug 22, 2019 11:36 am

I found a problem! Layers with controllers were locked.

Post Reply