manual IK-rigging doesn't work

Rigging, animation, import/export of characters, props and cameras comprehensive tool set for After Effects.
Forum rules
Please read these rules and advices before posting.
  • Before you ask any question about a tool, to avoid duplicates, please:
    1. Search for a solution in the available official user guide.
    2. Some video tutorials are available.
    3. Maybe you can find an answer in the frequently asked questions (FAQ).
    4. You can make a search to see if your question has already been asked.
    • Thank you for giving a detailed and precise title to your topics, to help searching in the future.
    • We're very few people to manage this forum, please be patient if we're a bit long to answer.
    • Don't hesitate to answer to other people's questions! The goal of this forum is not only to have the Rainbox team answer users' questions, but to have everyone sharing and helping each other.
    • Finally, please always be polite, and keep in mind that all we want is sharing techniques and knowledge, helping each other.
Post Reply
Erik
Posts: 4
Joined: Wed Sep 18, 2019 1:06 pm

manual IK-rigging doesn't work

Post by Erik » Thu Sep 19, 2019 11:46 am

I worked with Duik for 2 weeks now and I am super excited about it. However it showed so weird behaviour recently. What am I doing wrong?

I auto-create an Arm-Structure, click on S|Hand and create an Controller.
Well and then I select the Controller + S|Arm +S|Forearm and finally go under AutoRig&IK to the sub-menu.
I press IK and ...

then the magic wand pops up and everything stands still (- Duik crashed I think)

I reinstalled ae as well as Duik again but the same problems appear.

:/ What to do? I can't live without Duik anymore...

Erik
Posts: 4
Joined: Wed Sep 18, 2019 1:06 pm

Re: manual IK-rigging doesn't work

Post by Erik » Thu Sep 19, 2019 12:24 pm

the latest log...

=========== NEW LOG =============
=================================
[Thu Sep 19 2019 13:42:50 GMT+0200] || Warning || An error has occured in file
/Applications/Adobe%20After%20Effects%20CC%202019/Scripts/ScriptUI%20Panels/Duik%20Bassel.1.jsx
at line 22130

null is not an object
[Thu Sep 19 2019 13:47:40 GMT+0200] || Warning || An error has occured in file
/Applications/Adobe%20After%20Effects%20CC%202019/Scripts/ScriptUI%20Panels/Duik%20Bassel.1.jsx
at line 3885

Object is invalid
[Thu Sep 19 2019 13:47:51 GMT+0200] || Warning || An error has occured in file
/Applications/Adobe%20After%20Effects%20CC%202019/Scripts/ScriptUI%20Panels/Duik%20Bassel.1.jsx
at line 22130

null is not an object

Erik
Posts: 4
Joined: Wed Sep 18, 2019 1:06 pm

Re: manual IK-rigging doesn't work

Post by Erik » Thu Sep 19, 2019 5:48 pm

So after I deinstalled everything from Duik to AE and reinstalled it again and again I found the solution to simply switch back to Duik Bassel 16.0

User avatar
Duduf
Posts: 667
Joined: Mon Jun 20, 2016 2:59 pm

Re: manual IK-rigging doesn't work

Post by Duduf » Thu Oct 03, 2019 10:44 am

Thanks for the feedback, this will be fixed in the next update.

That said, you don't need to manually create IK in Duik Bassel, just create the structures, select all of them, click on auto-rig, et voilà!

Erik
Posts: 4
Joined: Wed Sep 18, 2019 1:06 pm

Re: manual IK-rigging doesn't work

Post by Erik » Thu Oct 10, 2019 8:50 am

Thanks for the answer and the great work.
I m doing this Rigging Course by School of Motion and going through all the processes that they mention - that's why I am doing manual as well.

thanks again and chapeau!

Post Reply